4 Replies Latest reply on Oct 11, 2018 8:45 AM by jamesdaga

    RCS Activation takes forever

    djdelarosa25

      I use the Android Messages app from Google and I'm also on Globe. It may be familiar to you that Globe has supported RCS for some time now. I tried enabling it in the app's settings but it's always stuck on the dreaded "Excuse the wait..." loading screen. For the record, I have been trying SINCE MAY. Four months nang ganyan pero wala pa rin.

       

      Screenshot of what I'm talking about:

      41840667_1863382873755838_3475236550919323648_n.jpg?_nc_cat=0&_nc_eui2=AeHSPnkJB16HgzYhb5U9gjNoS39hotOMkgD8Iyz7E4r1u9jC0lcoBatXVIs7VPv5uyRDD9rGq7dERLWOIvobMUrvjuWaLUa5Ywsp1W3ejR5UdA&oh=7a7700b733f92c6fa948998f859054f2&oe=5C2880E9

       

      Last week, a Pinoy Redittor told me to turn off the phone, remove the SIM card, turn it on, put the SIM card in, and then try to enable. It worked until a few days ago, when I did a factory reset on my phone. Now, it's back to the same issue that I had for months, and redoing the steps that I once did doesn't yield anything anymore. It's still stuck at the loading screen.

       

      I'm eager to hear experiences from you guys regarding this issue.

        • Re: RCS Activation takes forever
          jkcdarunday@gmail.com

          Happened to me as well. I figured that it is possible that the cell tower that I'm currently connected to may have issues so I manually switched it in the android settings and it worked.

           

          What I did on mine was:

          1. Go to Android Settings
          2. SIM cards & mobile networks
          3. Press TM/Globe
          4. Press Mobile networks
          5. Disable "Choose automatically"
          6. Wait for network search to finish
          7. Choose a different "Globe Telecom-PH" mobile network than the current one (there is usually two or more)
          8. Try to enable RCS in chat
          9. Repeat by choosing the other one if it didn't work.

           

          If none of the networks work, then towers near you may be having issues.

            • Re: RCS Activation takes forever
              izebeibie

              Hi! Ive been struggling to set this RCS feature up and stuck on with the blue screen, too - both me (Huawei P20 Lite) and husband (OppoF7) frustratingly, while the rest of our family already enjoys 'chatting' straight away without tweaking anything at all (they are on samsung, and huawei phones). Ive tried most of what you suggested except for resetting the phone. There are several network options to choose from globe 4G, globe 3G and so on, so do I try switching back in forth signals to see which going to work?

               

              So then, do you think this a network issue?

               

              Thank you, hoping for your kind response.

                • Re: RCS Activation takes forever
                  finickymia

                  Only 2 out of the 7 Android phones here have been activated. My Samsung S8 had no problem. My sister's Huawei tablet took about 3 weeks before RCS chat was activated. What remains stuck at "excuse the wait" are Huawei P20 lite, P10, Nova 3i, Samsung J7 and A5. I even went to a Globe store and their staff also wasn't able to activate his RCS on the spot. He escalated it to tech support but after 2 weeks I was notified that the case was returned to the Globe store where it was filed and no solution was provided because RCS activation was beyond the scope of their technical support.

                   

                  I hope they do something about this. I, too, have done all the steps available in reddit, the one above, etc. and it still didn't work.

              • Re: RCS Activation takes forever
                jamesdaga

                Same problem. Gamit ko yung Old sim ko. Iniisip ko baka di sya gumagana dahil old sim gamit ko. Tried all troubleshooting na naka post sa reddit at sa ilang forums, i already messaged Globe at Twitter pero in the end they advised me to go to the nearest Globe Store for assistance