6 Replies Latest reply on Apr 24, 2014 9:40 AM by hcescala

    Globe Micro SIM on iPad 2: Error Registering SIM

    RFCis

      Hi everyone, I'm at my wit's end on figuring out how to register a recently purchased Globe Micro SIM so I can use it with my iPad 3. I followed some simple instructions, place the SIM in the iPad, open the Globe app (which I downloaded from the App store) and hit register but unfortunately I always get the message "Error Registering SIM". I've tried resetting the network settings, I've tried resetting the iPad, I've tried to activate while connected/disconnected via Wifi, I've tried loading the SIM and then activate it and I even tried to register the SIM using an old iPad 2 but still I get the same message. The funny thing is that when I placed the SIM on my phone I was able to send/receive calls and SMS so I believe it's working fine. Then again I could be mistaken since I've been only receiving the same error message. Do you think it's a SIM issue or is it an App issue? Is there any other way that I can try to do to be able to finally activate the SIM?

        • Re: Globe Micro SIM on iPad 2: Error Registering SIM
          RNav

          RFCis If your APN in the Cellular Data Network settings is already http.globe.com.ph (prepaid) or internet.globe.com.ph (postpaid) and it still doesn't register, it could either be the SIM card or the Globe Services iPad app (as reported in another forum, it's an issue with an expired server). Perhaps you could visit the nearest GBC for further assistance/activation. In the meantime, try testing the iPhone version of the GServices app for account management.

          1 of 1 people found this helpful
          • Re: Globe Micro SIM on iPad 2: Error Registering SIM
            hcescala

            I have this issue before, the globe app does not work at all in registering your sim, anyway did you have signal on the ipad upon inserting the sim? if so then it is good to go

            • Re: Globe Micro SIM on iPad 2: Error Registering SIM
              RFCis

                   Thank you so much RNav, hcescala. I believe I have exhausted all means in self-managing this issue so I finally decided I had to make time to visit a GBC yesterday despite my fears of a long queue. I found myself talking to an agent relatively faster compared to the other times I had to visit a GBC but unfortunately they can't help me out as well.

                  

                   The problem according to them is the SIM card. Despite having purchased the micro SIM with the expressed intent to use it with an iPad directly from a GBC, they told me that the SIM that I got was incompatible with the Globe App because the iPad and Globe App can only work with a micro SIM. To calrify, they said that the SIM which was given to me, despite being a micro SIM, had an adapter for a regular sized SIM card and thus it was incompatible with the iPad and Globe App at the moment. Only the standalone micro SIM cards, those without an adapter, issued by Globe will work with an iPad and Globe App.


                       They did suggest that for the mean time if I'd like to subscribe on Globe's data services I have to pull out the SIM, insert it on a phone, register for a data plan and then put it back in the iPad to be able use the data services.


                   We'll perhaps this is a deeper technical issue behind it all but I rather not to hear it at that time because I was disappointed that I was sold an item which was different from what I asked for. I am still hopeful that a day will come when this issue will be resolved but for now I am left with two options, purchase a new micro SIM or follow their round about advice for the data services.


              I advice those who will buy a micro SIM from any GBC to make sure that the SIM you will get is the plain micro SIM, not the one with the adapter to be a regular sized SIM if you plan to use it with a Globe App in an iPad. Lesson learned.