1 Reply Latest reply on Nov 16, 2015 5:53 PM by Paulo D

    Incorrect Promo Details and Balance

    celes1023

      Hello Globe! I have been a customer for more than 15 years! Way back when phones were still analog types and single screen. My current number has been on service for 2 years and 5 months. I'm using an iPhone 4 the same time I got my current number and has been like that since.

       

      Having a blog and constant need for data access for my studies, I register to GoSakto GOTSCOMBODD70 every week, an hour before the promo expires to accumulate any unused services and roll over to the next week. However, last Sarurday, November 14, 2015. I fell asleep while studying, and was not able to register to  GOTSCOMBODD70 before it expires. Accepting that this is my fault, I brush off any anger I felt for my self and contemplate that I just lost almost 8k Globe to Globe texts and 2.6G of data access. I usually expire the texts and keep the data. Since I already lost them, I opt to start anew and registered again for GOTSCOMBODD70. I got the usual notification of thanks and congrats, was provided with 1000 Globe to Globe texts and 1000MB for data access.

       

      I used the service seamlessly, instagram, safari, and youtube. It was unusual to have fast data connection where I lived. It is always faster when I'm at school or work. When I checked my data usage on Sunday, November 15, 2015 around 12noo. it is just around 340MB ... I turned off data eat my lunch, watch a few movies on DVD and tried checking my emails around 4:00pm. I turned on my data, it shows the 3G symbol and the usual 3 round signal bars... But heck its not connecting! None at all, I performed all possible troubleshooting steps that I could think of but none of them worked. I tried checking my GoSakto balance but didnt get a response, I tried again and got a system detection of multiple attempts to register. Hell! I'm not even registering! I'm trying to check my data balance! I tried every few hours and got the same response. Except this morning, November 16, 2015 , I got a system cannot Process your request. With this I concluded something is wrong with your service. I tried inserting my  SIM to a friend's phone but got the same results. Internet does not connect and balance inquiry isnt processing. I tried to redeem a globe rewards but also got a not being processes response.

       

      I finally redeemed a GoSurf30 and concluded that the system is already up! I inquire my GoSakto balance and was surprised and irritated when it says I have a 7k globe to globe txts and just 60440kb data, I mean what the heck? My txts were supposed to be just around 900 and my data should be 650MB .. Please correct this! paulos globelive